[solved] Administrator privileges required on some generated program files?

About Monkey 2 Forums Monkey 2 Programming Help [solved] Administrator privileges required on some generated program files?

This topic contains 3 replies, has 3 voices, and was last updated by  jihem 2 years, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1591

    jihem
    Participant

    I made 2 files (window_simple.monkey2, window_update.monkey2). I can launch the first with [F6] but not the second. The second exe has a shield on his icon and requires administrator privileges. I done nothing special (only display a window and move a text with the joystick). The two monkey2 files are in the same folder and are built from ted2 in the same session. Ted2 is launched normally (without privileges). The install is in a folder (monkey2-v1.0.0) on the root of drive C. I use Windows 10.

    Any idea?

    #1592

    Mark Sibly
    Keymaster

    No idea sorry – I don’t do anything ‘special’ when making apps and have never had any admin problems.

    Try a reboot? Delete both .build dirs and try again?

    #1593

    Danilo
    Participant

    jihem:
    Try renaming window_update.monkey2 to window_updt.monkey2 or similar –
    AFAIK it’s a special Windows OS “feature” for .exe that contain “update”,
    “install”, “patch”, and “setup” in the filename.

    EDIT:
    See also the following pages:
    http://stackoverflow.com/questions/20096706/how-does-windows-decide-whether-to-display-the-uac-prompt
    http://math.nist.gov/oommf/software-patchsets/patch_on_Windows7.html
    https://technet.microsoft.com/en-us/library/jj574202(v=ws.11).aspx

    #1596

    jihem
    Participant

    Thanks for you help. It’s very nice. Is there a way to tag the subject as ‘solved’?

    @Mark Sibly
    We have had the same ideas… but this doesn’t work.

    @danilo
    You got it! It’s related to the name. I remove the word ‘update’ and everything goes as expected. I’ll make a blacklist of words adding this one.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.