Audio on Linux. Any success?

About Monkey 2 Forums Monkey 2 Programming Help Audio on Linux. Any success?

Tagged: ,

This topic contains 4 replies, has 3 voices, and was last updated by  wiebow 3 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1601

    wiebow
    Participant

    Hello all,

    I am running the vSynth banana, and I am getting no sound. I’ve been experimenting with sound today and despite my efforts, I cannot get any audio to play.

    Has anyone here had the same experience or fixed it? Does anyone know the dependancies of audio on Linux with Monkey2?

    I am running Linux Mint 17.3 btw.

    #1603

    Simon Armstrong
    Participant

    From command line go to monkey2/bananas/spacechimps/assets and

    aplay -vv bang.wav

    This works for me on a peppermint vbox mac session (as does vsynth).

    The most common one in my experience is the default port is wrong so I suggest start checking output of all jacks on your computer.

    My Pi defaulted to digital on hdmi so that was pretty nuts to find.

    http://www.alsa-project.org/main/index.php/SoundcardTesting

    #1608

    Simon Armstrong
    Participant

    According to SDL2 module file SDL_config_linux.h monkey2 is actually using Pulse audio on linux not ALSA.

    #1611

    jondecker76
    Participant

    Audio is working fine here on a vanilla Ubuntu 16.04 64 bit install

    #1631

    wiebow
    Participant

    Simon: thanks, that was the problem… I am going to set my default cards like described on that page, because this is changing too often. Or I will disable the onboard sound card.  I have the same problem sometimes with games I play through Steam.

    Again, thanks all!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.