Can't build with MSVC2017

About Monkey 2 Forums Monkey 2 Development Can't build with MSVC2017

This topic contains 5 replies, has 3 voices, and was last updated by  Mark Sibly 2 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #14993

    cocon
    Participant

    Building with MSVC2017 always worked for me perfectly, normally I would double click the rebuildall2go.bat and it would start the process.

    The last week I did some updates to Visual Studio and now it can’t build, this time I event tried running the script from “Developer Command Prompt” – just in case it would help.

     

    output from command prompt

     

    output from stdout1.txt:

     

    Perhaps if this is a dumb error (due to some mis-configuration) I might try to setup my OS from scratch again. 🙂

    #15000

    c0d3r9
    Participant

    Don´t know if thats the reason but in env_windows.txt i change always this

    MX2_MSVC_TOOLS_DIR=${MX2_MSVC_DIR}\Tools\MSVC\14.14.26428

    to the correct version

    #15001

    cocon
    Participant

    Alright thanks, now the building started nicely.

    These are the correct settings:

    #15019

    Mark Sibly
    Keymaster

    Hezkore promised to do me an autodetect for this!

    #15020

    c0d3r9
    Participant

    Thats only a few lines.Not to much work for us 😉

    Btw. anyway i have to change

    to

    #15021

    Mark Sibly
    Keymaster

    …and no doubt it’ll all change one day not too far off anyway…

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.