Emscripten: 'em++' is not recognized

About Monkey 2 Forums Monkey 2 Programming Help Emscripten: 'em++' is not recognized

This topic contains 57 replies, has 7 voices, and was last updated by  Richard Betson 1 year, 5 months ago.

Viewing 15 posts - 31 through 45 (of 58 total)
  • Author
    Posts
  • #10570

    CopperCircle
    Participant

    @hezkore, looking at your emsdk log looks like you need git installed to get the latest tagged release, git is install on my machine and it updates to 1.37.9 fine.

    #12337

    regulark
    Participant

    @jesse did you ever resolve this issue? I get the same error when compiling to wasm

    #12338

    Jesse
    Participant

    I haven’t used Emscripten since posting the issue. I was waiting for it to become more stable with the language. I no longer have the itch.io version. I am using the development version. But even that give me errors:

    Parsing…
    Semanting…
    Translating…
    Compiling…
    Build error: System command failed:

    emcc -c -std=gnu99 -s USE_SDL=2 -s TOTAL_MEMORY=268435456 -s DISABLE_EXCEPTION_CATCHING=1 -O3 -DNDEBUG -I”/Users/jesse/monkey2/modules/” -I”/Users/jesse/monkey2/modules/monkey/native” -o “/Users/jesse/monkey2/modules/opengl/opengl.buildv1.1.09/emscripten_release/build/_1_1_1native_2bbopengl.c.o” “/Users/jesse/monkey2/modules/opengl/native/bbopengl.c”

    /Users/jesse/monkey2/modules/opengl/native/bbopengl.c:41:20: error: implicit declaration of function ‘SDL_GL_ExtensionSupported’ is invalid in C99 [-Werror,-Wimplicit-function-declaration]
    BBGL_draw_buffers=SDL_GL_ExtensionSupported( “GL_WEBGL_draw_buffers” );
    ^
    1 error generated.
    ERROR:root:compiler frontend failed to generate LLVM bitcode, halting

    ***** Fatal mx2cc error *****

    Internal mx2cc build error

    Update modules failed.
    Total time elapsed: 3 m 44 s.

    I’ll try the itch.io and report back.

    [edit]

    I did try the Itch.io version but it gives me this errors:

    Mx2cc version 1.1.08

    ***** Building app ‘/Applications/Monkey2-v1.1.08/bananas/particles/particles.monkey2′ *****

    Parsing…
    Semanting…
    Translating…
    Compiling…
    Linking /Applications/Monkey2-v1.1.08/bananas/particles/particles.products/Emscripten/Particles.js…
    Build error: System command ’em++ -s USE_SDL=2 -s TOTAL_MEMORY=268435456 -s DISABLE_EXCEPTION_CATCHING=1 -O2 –preload-file “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/assets/@/assets” -s BINARYEN=1 -s BINARYEN_TRAP_MODE=’allow’ -o “/Applications/Monkey2-v1.1.08/bananas/particles/particles.products/Emscripten/Particles.js” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2mojo_2mojo.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2std_2std.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2stb_5vorbis_2stb_5vorbis.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2stb_5image_5write_2stb_5image_5write.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2stb_5image_2stb_5image.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2miniz_2miniz.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2sdl2_2sdl2.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2jni_2jni.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2openal_2openal.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2gles20_2gles20.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2libc_2libc.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2freetype_2freetype.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2emscripten_2emscripten.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2monkey_2monkey.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/particles_0particles.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/particles_0monkey_0math.cpp.o” “/Applications/Monkey2-v1.1.08/modules/mojo/mojo.buildv1.1.08/emscripten_debug/mojo.a” “/Applications/Monkey2-v1.1.08/modules/std/std.buildv1.1.08/emscripten_debug/std.a” “/Applications/Monkey2-v1.1.08/modules/stb-vorbis/stb-vorbis.buildv1.1.08/emscripten_debug/stb-vorbis.a” “/Applications/Monkey2-v1.1.08/modules/stb-image-write/stb-image-write.buildv1.1.08/emscripten_debug/stb-image-write.a” “/Applications/Monkey2-v1.1.08/modules/stb-image/stb-image.buildv1.1.08/emscripten_debug/stb-image.a” “/Applications/Monkey2-v1.1.08/modules/miniz/miniz.buildv1.1.08/emscripten_debug/miniz.a” “/Applications/Monkey2-v1.1.08/modules/sdl2/sdl2.buildv1.1.08/emscripten_debug/sdl2.a” “/Applications/Monkey2-v1.1.08/modules/jni/jni.buildv1.1.08/emscripten_debug/jni.a” “/Applications/Monkey2-v1.1.08/modules/openal/openal.buildv1.1.08/emscripten_debug/openal.a” “/Applications/Monkey2-v1.1.08/modules/gles20/gles20.buildv1.1.08/emscripten_debug/gles20.a” “/Applications/Monkey2-v1.1.08/modules/libc/libc.buildv1.1.08/emscripten_debug/libc.a” “/Applications/Monkey2-v1.1.08/modules/freetype/freetype.buildv1.1.08/emscripten_debug/freetype.a” “/Applications/Monkey2-v1.1.08/modules/emscripten/emscripten.buildv1.1.08/emscripten_debug/emscripten.a” “/Applications/Monkey2-v1.1.08/modules/monkey/monkey.buildv1.1.08/emscripten_debug/monkey.a” ‘ failed.

    em++ -s USE_SDL=2 -s TOTAL_MEMORY=268435456 -s DISABLE_EXCEPTION_CATCHING=1 -O2 –preload-file “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/assets/@/assets” -s BINARYEN=1 -s BINARYEN_TRAP_MODE=’allow’ -o “/Applications/Monkey2-v1.1.08/bananas/particles/particles.products/Emscripten/Particles.js” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2mojo_2mojo.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2std_2std.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2stb_5vorbis_2stb_5vorbis.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2stb_5image_5write_2stb_5image_5write.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2stb_5image_2stb_5image.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2miniz_2miniz.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2sdl2_2sdl2.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2jni_2jni.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2openal_2openal.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2gles20_2gles20.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2libc_2libc.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2freetype_2freetype.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2emscripten_2emscripten.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/_1_1_1_1_1modules_2monkey_2monkey.buildv1.1.08_2emscripten_0debug_2include_2_0r.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/particles_0particles.cpp.o” “/Applications/Monkey2-v1.1.08/bananas/particles/particles.buildv1.1.08/emscripten_debug/build/particles_0monkey_0math.cpp.o” “/Applications/Monkey2-v1.1.08/modules/mojo/mojo.buildv1.1.08/emscripten_debug/mojo.a” “/Applications/Monkey2-v1.1.08/modules/std/std.buildv1.1.08/emscripten_debug/std.a” “/Applications/Monkey2-v1.1.08/modules/stb-vorbis/stb-vorbis.buildv1.1.08/emscripten_debug/stb-vorbis.a” “/Applications/Monkey2-v1.1.08/modules/stb-image-write/stb-image-write.buildv1.1.08/emscripten_debug/stb-image-write.a” “/Applications/Monkey2-v1.1.08/modules/stb-image/stb-image.buildv1.1.08/emscripten_debug/stb-image.a” “/Applications/Monkey2-v1.1.08/modules/miniz/miniz.buildv1.1.08/emscripten_debug/miniz.a” “/Applications/Monkey2-v1.1.08/modules/sdl2/sdl2.buildv1.1.08/emscripten_debug/sdl2.a” “/Applications/Monkey2-v1.1.08/modules/jni/jni.buildv1.1.08/emscripten_debug/jni.a” “/Applications/Monkey2-v1.1.08/modules/openal/openal.buildv1.1.08/emscripten_debug/openal.a” “/Applications/Monkey2-v1.1.08/modules/gles20/gles20.buildv1.1.08/emscripten_debug/gles20.a” “/Applications/Monkey2-v1.1.08/modules/libc/libc.buildv1.1.08/emscripten_debug/libc.a” “/Applications/Monkey2-v1.1.08/modules/freetype/freetype.buildv1.1.08/emscripten_debug/freetype.a” “/Applications/Monkey2-v1.1.08/modules/emscripten/emscripten.buildv1.1.08/emscripten_debug/emscripten.a” “/Applications/Monkey2-v1.1.08/modules/monkey/monkey.buildv1.1.08/emscripten_debug/monkey.a”

    Traceback (most recent call last):
    File “/Users/jesse/emsdk/emscripten/1.37.9/em++”, line 16, in <module>
    emcc.run()
    File “/Users/jesse/emsdk/emscripten/1.37.9/emcc.py”, line 1033, in run
    exec ‘shared.Settings.’ + key + ‘ = ‘ + value in globals(), locals()
    File “<string>”, line 1, in <module>
    NameError: name ‘allow’ is not defined

    ***** Fatal mx2cc error *****

    Internal mx2cc build error

    I am using emsdk 1.37.9

    #12364

    Mark Sibly
    Keymaster

    I have just pushed a fix for the opengl build error to the develop branch, although weirdly I’m not getting this error myself! It is a valid error though…

    #12365

    regulark
    Participant

    Great! I can compile the develop branch without a hitch, and compile projects to asmjs but when compiling to wasm I still receive the ‘NameError: name ‘allow’ is not defined’ error. Any ideas?

    #12366

    Jesse
    Participant

    I am getting the same error Mark. It’s the same as what I posted in my previous post. That’s with your newest modification.

    I think the root of the problem is that we are using the newest Emscripten(1.37.9) vs the version that Mark seems to be using (1.35.0). When I had 1.35.0 I didn’t have that problem.

    #12451

    Jesse
    Participant

    Bump.

    #12452

    Mark Sibly
    Keymaster

    Well, I *was* using 1.37.9, but went back to using ‘latest’ as others seemed to be having problems installing 1.37.9 and ‘latest’ was working fine for me – still is! In fact, emscripten has always worked for me, amazingly…

    I though it’d be best just to try and use the version installed by ’emsdk install latest’ so everyone was on the same page and it’s probably what we’re supposed to be using?

    I am also now a bit unclear on exactly where people are even getting 1.37.9 from too, or are they rebuilding from source?

    Using the emsdk-portable-64bit, if I go ’emsdk update’ it says:

    But of course, true to form, if I install/activate latest I only get 1.37.26!

    If I go ’emsdk list’ I can see some precompiled 1.37.9 versions that look like they’re from April. In fact, here’s my whole emsdk list output:

    So which 1.37.9 are people actually using, and how are they installing it, and which version do they actually get if they just install/activate ‘latest’?

    #12453

    Mark Sibly
    Keymaster

    Ok, think I know where the “NameError: name ‘allow’ is not defined” error is coming from.

    I would still like to know what version of emscripten people are running and how they are installing it. It does seem like there are numerous issues related to different versions of emscripten, which is understandable I guess.

    Another thing to note is that after activating ‘latest’ with emsdk, I have to go through and manually update a bunch of env vars and PATH settings to point to various things inside emsdk dir. The emsdk tries to do this but of course all env vars are lost as soon as you close the console.

    I did waste a day+ trying to put together a truly portable emsdk but gave up in the end. I am kind of hpoing some 3rd party will grab the bull by horns and release an emsdk-deluxe that ‘just works’ and sets up paths properly and everything.

    #12454

    Mark Sibly
    Keymaster

    The ‘allow’ error looks like it was caused by a emscripten linker option hardcoded into mx2cc. I have tweaked mx2cc so this option is now configurable via bin/env_windows.txt etc:

    MX2_LD_OPTS_EMSCRIPTEN_WASM=-s BINARYEN=1 -s BINARYEN_TRAP_MODE=’allow’

    This is just what used to be hardcoded into mx2cc – all I can say for sure is that it works on MY setup!

    To build with 1.37.9 you’ll (probably) need to change this to:

    MX2_LD_OPTS_EMSCRIPTEN_WASM=-s BINARYEN=1

    Note that this var is appended to MX2_LD_OPTS_EMSCRIPTEN when building wasm (or wasm+asmjs) apps.

    Not the prettiest, but I’m gonna stick with emsdk ‘latest’ versions for now as they seem to be easiest to install, and this does at least let you experiment with later versions that may break some stuff. Well, when it comes to LD opts anyway.

    You’ll need to grab the latest from develop and updatemx2cc for this to work. Assuming it does work, as I’m running emsdk v1.37.26 and haven’t tested it with any 1.37.9 version yet.

    #12455

    Jesse
    Participant

    You are not going to like this.
    I uploaded the Emscripten(it’s up to 1.37.27 now). from the link you have above and followed the direction to install it, I downloaded the latest Monkey 2 from the repository, build modules etc.. then run Ted2go, updated modules for Emscripten. Everything worked fine. No problems! Until I tried to run a program that runs fine in desktop. then I got this:

    Compiling…
    Linking /Users/jesse/Desktop/collision.products/Emscripten/Collision.js…
    Build error: System command failed:

    em++ -s USE_SDL=2 -s TOTAL_MEMORY=268435456 -s DISABLE_EXCEPTION_CATCHING=1 -O2 –preload-file “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/assets/@/assets” -s BINARYEN=1 -s BINARYEN_TRAP_MODE= -o “/Users/jesse/Desktop/collision.products/Emscripten/Collision.js” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2mojo_2mojo.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2std_2std.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2stb_5vorbis_2stb_5vorbis.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2stb_5image_5write_2stb_5image_5write.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2stb_5image_2stb_5image.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2miniz_2miniz.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2sdl2_2sdl2.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2jni_2jni.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2opengl_2opengl.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2openal_2openal.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2libc_2libc.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2freetype_2freetype.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2emscripten_2emscripten.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/_1_1_1_1monkey2_5develop_2modules_2monkey_2monkey.buildv1.1.09_2emscripten_0debug_2include_2_0r.cpp_r.o” “/Users/jesse/Desktop/collision.buildv1.1.09/emscripten_debug/build/collision_0collision.cpp.o” “/Users/jesse/monkey2-develop/modules/mojo/mojo.buildv1.1.09/emscripten_debug/mojo.a” “/Users/jesse/monkey2-develop/modules/std/std.buildv1.1.09/emscripten_debug/std.a” “/Users/jesse/monkey2-develop/modules/stb-vorbis/stb-vorbis.buildv1.1.09/emscripten_debug/stb-vorbis.a” “/Users/jesse/monkey2-develop/modules/stb-image-write/stb-image-write.buildv1.1.09/emscripten_debug/stb-image-write.a” “/Users/jesse/monkey2-develop/modules/stb-image/stb-image.buildv1.1.09/emscripten_debug/stb-image.a” “/Users/jesse/monkey2-develop/modules/miniz/miniz.buildv1.1.09/emscripten_debug/miniz.a” “/Users/jesse/monkey2-develop/modules/sdl2/sdl2.buildv1.1.09/emscripten_debug/sdl2.a” “/Users/jesse/monkey2-develop/modules/jni/jni.buildv1.1.09/emscripten_debug/jni.a” “/Users/jesse/monkey2-develop/modules/opengl/opengl.buildv1.1.09/emscripten_debug/opengl.a” “/Users/jesse/monkey2-develop/modules/openal/openal.buildv1.1.09/emscripten_debug/openal.a” “/Users/jesse/monkey2-develop/modules/libc/libc.buildv1.1.09/emscripten_debug/libc.a” “/Users/jesse/monkey2-develop/modules/freetype/freetype.buildv1.1.09/emscripten_debug/freetype.a” “/Users/jesse/monkey2-develop/modules/emscripten/emscripten.buildv1.1.09/emscripten_debug/emscripten.a” “/Users/jesse/monkey2-develop/modules/monkey/monkey.buildv1.1.09/emscripten_debug/monkey.a”

    Traceback (most recent call last):
    File “/Users/jesse/emsdk-portable/emscripten/1.37.27/em++”, line 16, in <module>
    emcc.run()
    File “/Users/jesse/emsdk-portable/emscripten/1.37.27/emcc.py”, line 903, in run
    if value[0] == ‘@’:
    IndexError: string index out of range

    ***** Fatal mx2cc error *****

    running OS X Sierra 10.12.6

    #12467

    Mark Sibly
    Keymaster

    You are not going to like this.

    No problem, we’ll get there!

    I think I know what’s up to0 (and why I originally hardcoded LDWASM opts into mx2cc) – the apostrophe is behaving like a comment in the env.txt file.

    Will do some tweaking…

    #12468

    Mark Sibly
    Keymaster

    You are not going to like this.

    No problem, we’ll get there!

    I think I know what’s up too (and why I originally hardcoded LD WASM opts into mx2cc) – the apostrophe is behaving like a comment in the env.txt file.

    Will do some tweaking…

    #12469

    Mark Sibly
    Keymaster

    Well waddya know, looks like I didn’t even properly test my last little fix as I get the same error here! Probably built the wrong target…huge apologies….there may have been small amounts of beer involved…am running purely on caffeine today, promise!

    #12470

    Mark Sibly
    Keymaster

    Ok, just pushed a potential fix to develop branch.

    I had to change the ‘comment’ system in the env var files a bit. Comment chars must now appear at beginning of a line only, this allows for apostrophes in env vars so =’allow’ should work now.

    Have tested it here but only on Windows as I have *never* been able to successfully install emscripten on macos for some reason!

    So any problems you may have will probably be in bin/env_macos.txt. I had to change this a bit and remove any ‘inline comments’ (there were a few in there).

Viewing 15 posts - 31 through 45 (of 58 total)

You must be logged in to reply to this topic.