error: use of undeclared identifier 'EACCES'

About Monkey 2 Forums Monkey 2 Development error: use of undeclared identifier 'EACCES'

This topic contains 10 replies, has 6 voices, and was last updated by  arpie 2 weeks, 1 day ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #14896

    Amon
    Participant

    I grabbed the latest github source about 30 minutes ago. I updated mx2cc to 1.14 and rebuilt modules. Android fails to rebuild with the error above. I’m using NDK r13b.

    #14939

    Amon
    Participant

    Bump

    #14942

    abakobo
    Participant

    same here (W10).. may be we have to update something?

    Edit:
    working on my mac, will compare versions.

    #14946

    c0d3r9
    Participant

    For fun i build monkey2 from source with the sources last night.

    edit: if i build then any example it fails with ***** Fatal mx2cc error *****

    I think its caused because mark have change anything in code.

    I have a build one or two weeks ago and all runs fine.

    #14968

    Mark Sibly
    Keymaster

    Android building fine here on windows 10.

    NDK r13b.

    That’s quite old, I am using 17.0.something plus there are updates – installing now.

    edit: if i build then any example it fails with ***** Fatal mx2cc error *****

    Have you rebuilt everything? There have been mx2cc changes recently which means mx2cc will need to be rebuild too.

    Anyone else?

    #14970

    Mark Sibly
    Keymaster

    OK, things may be a bit rocky on the develop branch until thread support is integrated, although there is still no reason for the EACCES error AFAICT so please update your NDK and see if that helps.

    I have successfully updated android components here to Android Studio 3.1.3 ; Android SDK 27 (Oreo 8.1) ; NDK 17.1.4828580 ; Android SDK Tools 26.1.1 and all appears to be OK. I can run the mojo3d template app on an API 27 emulator anyway, yay!

    #14972

    c0d3r9
    Participant

    I think my error message from a sample code in the developer branch was somewhat unfinished.

    I built a working 2018-06 some weeks ago.
    For me all fine atm.
    We shouldn´t forget that are developer branches  😉

    #14977

    SekaiChi
    Participant

    Here it is possible to compile to android on mac at least, (there is no the room for trying android on my small window machine so only the mac can be used for multiplatform compilations).

    #15022

    Amon
    Participant

    Hi Mark. I’ve updated everything and I still can’t rebuild android. With the latest source from github I get this error with NDK r17b when trying to rebuild modules for android…

     

    Mx2cc version 1.1.15

    ***** Making module ‘monkey’ (android release armeabi-v7a x86 gcc) *****

    Parsing…
    Semanting…
    Translating…
    Compiling…
    [armeabi-v7a] “Compile++ thumb”: “mx2_monkey <= monkey_monkey.cpp”
    Build error: System command failed:

    ndk-build

    The system cannot find the path specified.
    make: *** [obj/local/armeabi-v7a/objs/mx2_monkey/__/src/monkey_monkey.o] Error 1

    ***** Fatal mx2cc error *****

    Internal mx2cc build error

    Rebuild modules failed.
    Total time elapsed: 0 m 0 s.

    #15029

    Mark Sibly
    Keymaster

    Have you rebuilt mx2cc too?

    The github develop branch is pretty volatile, esp. right now while threads are being added. Perhaps stick with binary releases instead for a bit?

    #15499

    arpie
    Participant

    It seems I’m a bit late to this party but just solved this issue here.  On linux there doesn’t seem to be a standard place to install the ndk bundle.  Your distro package will probably put it under /opt/android or some such, but Android Studio will manage the ndk bundle updates somewhere else (in my case ~/Android/Sdk/ndk-bundle).  I told monkey where to find it by adding these lines to the end of <monkey>/bin/env_linux.txt (based on similar lines in env_macos.txt) :

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.