System Command Failed

About Monkey 2 Forums Monkey 2 Development System Command Failed

This topic contains 5 replies, has 3 voices, and was last updated by  Amon 3 months, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #14420

    Amon
    Participant

    Just now downloaded the latest repo from github. I’m trying to build with MSVC Pro 2017. It started building but failed at making the stb module with the following error:

     

    I’m going to try with MINGW now to see if the same happens. Will report back in a bit.

    #14422

    nerobot
    Participant

    Maybe you need fresher version of mx2cc to compile.

    #14429

    Mark Sibly
    Keymaster

    Can you try git pulling again?

    I added a tweak to std module.json late last night which might fix this…

    Also, I recommend you update the compler too – you’re on v1.1.09 but mx2cc is up to 1.1.12 now. Mixing older compiler with newer modules is likely to cause problems sooner or later…

    To update mx2cc, just execute the updatemx2cc script after git pulling.

    #14432

    Amon
    Participant

    A fresh git pull just now and executing updatemx2cc from the command line gives the following error on std module again.

    #14449

    Mark Sibly
    Keymaster

    Oops, please try again now.

    If it’s still borked, please try executing an updatemods.bat first. The mx2cc builds scripts were missing zlib…

    #14459

    Amon
    Participant

    All working fine. Everything updated and built. 🙂

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.