Ted 2 on Mac OSX

About Monkey 2 Forums Monkey 2 Development Ted 2 on Mac OSX

This topic contains 8 replies, has 4 voices, and was last updated by  Arjailer 2 years, 10 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2546

    Arjailer
    Participant

    Trying out Monkey 2 on my MacBook (OSX 10.11.6).

    Downloaded the source and built it as per the readme.

    Ted 2 runs and appears to build code okay (tried my own code + the bananas), but it doesn’t actually seem to run the built code. The built applications are in the expected output folders and if I run them manually they work fine, but Ted 2 doesn’t seem to want to run them, which makes development and debugging pretty difficult ¬†ūüôā

    Anyone got any ideas?

    #2554

    Jesse
    Participant

    it works fine on my MacBook with the latest OSX. What version of OSX are you using? Have you installed the latest tools?

    #2556

    Arjailer
    Participant

    OSX is 10.11.6 as stated (the latest version).

    Latest command line tools installed (at least I ran the command in the readme and it said they were already installed).

    I habitually keep all my computers and software up to date (I loooove an update) apart from my work machine, which they’re keeping on Windows 7.

    #2562

    Simon Armstrong
    Participant

    Have you tried running the launcher Monkey2 (Macos).app?

    Are you using a plain ~/monkey2 installation folder? It sounds like some kind of permissions issue. Either security or Read and Write folder thing perhaps.

    Also there is a tmp folder that monkey2 uses which you may want to check has been created ok in ~/monkey2/tmp.

    #2572

    Arjailer
    Participant
    • Monkey2 (Macos).app – yep, using that.
    • ~/monkey2 installation folder – my folder is deeper, will try moving it to a shallower folder later.
    • Permissions – not convinced – it creates the built app fine, which I can run manually, it just doesn’t run it from Ted and there’s no error, just “Done”. I’ll check later though.
    • ~/monkey2/tmp – yep, that’s there.
    #2578

    cocon
    Participant

    As I remember Macs have this console logger and might catch any errors.
    https://support.omnigroup.com/console-osx/

    Also another case is that by building with terminal to see if everything goes well, because TED will not show any g++ or OS related errors.
    D:\Programs\monkey2\scripts

    Regarding the permissions: You will need to check the mx2cc application (My is D:\Programs\monkey2\bin\mx2cc_windows.exe), in which user group it belongs? Because this application is responsible for invoking a system process (the game you want to run), you will have to make sure that it has the appropriate permissions to so (perhaps other Mac users could validate this). Also I would be keep an eye if one folder on tree has restricted rights, thus applying restritions to the monkey2 folder as well.

    Sorry for the guesswork, I hope that anything of these help.

    #2585

    Arjailer
    Participant

    Okay – figured it out – was spaces in the path.

    I had it in “~/development/monkey¬†2” – removed the space and it now works.

    Spaces in the path are fine in Windows 7 and 10.

    Nice to get it working on my MacBook ¬†ūüôā

    #2599

    cocon
    Participant

    That’s good, perhaps a patch would be created to fix this if it’s considered as a bug¬†by escaping the white spaces in Unix OSs’.

    #2627

    Arjailer
    Participant

    I’ve logged it as a issue.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.